Processing 3.0.2 won't run sketches

edited April 2016 in Using Processing

I've installed processing 3.0.2 on arch linux , all installs as predicted . When i run a sketch i get nothing , no sketch window , no errors . I've tried jre 7 and 8 with no results , also tried installing processing with pacman and from source.

I presume this is a java issue but can't work out what the issue is. Sketches run in browser.

also if i activate debugging mode processing hangs.

Please help if you can .

Running processing 3.0.2 in windows and enjoying the increased speed it has , but would love to get it running for linux install.





  • edited April 2016
    • Processing doesn't have an actual installer. Neither for Linux nor even for Windows. Except Mac.
    • It's merely a standalone app which we just throw at some arbitrary folder and run its launcher.
    • In Linux, there's an extra step of setting the exec bit for the launcher.
    • But that's the only apparent diff. between Linux & Windows versions aFaIK.
  • Ok ..... guessing it's definatley a java issue thats stoping sketches from doing anything .

    Any idea what would crash the debugger , or a way of getting more feedback. If i run procesing from the terminal i get no feedback at all , just space created.

  • Only thing I know I've always succeeded to run Processing under any Ubuntu-based distro:

  • just use VirtualBox application and try.... you can download from here

  • edited April 2016

    I've tried jre 7 and 8 with no results

    the JRE? the JRE doesn't include javac so you won't be able to compile anything if you're only using the JRE.

    what does java -version say? which javac?

    there was an embedded java included with processing. isn't this still the case?

  • There is an embedded java with processing but ...

    "Most problems on Linux come from the version of Java that's included in the download being incompatible with the OS. In that case, remove (or rename) the included ‘java’ folder, and replace it with a usable version of the JRE 7. You can also symlink it to a JRE that's installed on your machine. Be sure that the symlink is set up relative to the ‘processing’ shell script such that ./java/bin/java points to the ‘java’ binary. Take a look at the folder structure of the included ‘java’ folder to see how it works." -from docs

    so tried replacing java folder with jre7 ( didn't work , though maybe i did it incorectly ) - i will try again today.

    • java version is

    • no javac , though docs say that processing 3 dosen't need jdk (which i presume is where javac comes from) , and will run with just jre installed.

      "Since Processing 2.1, a full JDK is no longer required on Linux. Just the JRE."

    thanks for the ideas .

Sign In or Register to comment.