Can't get some JRubyArt sketches to work. Please help.

I'm thinking more specifically of those involving the video and pdf libraries. Though there are also other sketches from the examples that won't work. I get errors similar to this with the video and pdf examples:

I've configured my config.yml like this:

--- # config.yml
PROCESSING_ROOT: E:\processing-3.0.2 Windows
JRUBY: true
sketchbook_path: E:\Dropbox\JULIO\GENERATIVE ALGORITHMIC\P5 3

Things I've already tried:

  • Recreating the file structure of a sketch with the respective libraries:

  • Running the video sketches with the --nojruby flag as suggested by monkstone himself:

  • Copying jruby complete to the vendors folder, including another folder which k9 indicated and with another name:

There are other sketches that don't use external libraries that also produce strange errors. This one is when running pointillism.rb:

Also I must mention that k9 setup install never worked properly. I tried to run it again but I get a very different error about rake being missing:

Please help! :(



  • edited April 2016

    The k9 setup install depends on wget, which you may not have installed, however what that does is download jruby-complete to the vendors folder of the gem, this is controlled by the Rakefile in the vendors folder. Which checks for the downloaded file (so you can bypass the wget download ) and strips the version and copies it to the lib/ruby folder as jruby-complete.jar so you can bypass the lot by just renaming a manually downloaded jruby-complete.jar and putting in the lib/ruby folder of the installed gem.

    The library issue may be a path issue (I don't have windows so can't check) but you can check by creating a copy of library local to sketch. For video library create a folder 'video' nested in 'library' folder and put the video.jar etc in that folder (library/video/video.jar etc). PS video sketches require to run with the jruby-complete (not an installed jruby) and hence need the '--nojruby' flag.

  • Hey, monkstone. Thanks for answering and sorry for the delay but I've been very busy with some other stuff.

    I did install wget and added it to my PATH variable, but I still got errors about wget not being installed when running k9 setup install.

    Also, I did try to replicate the video library folder structure under the sketch folder as you can see in one of the pictures I uploaded, but it didn't work. I thnik I'm indeed going to report an issue. Thank you very much for your time again.

Sign In or Register to comment.