Processing 3.0 and 3.0.1 start problem - in windows domain environment

edited September 11 in Using Processing

hello, I would test the new processing 3.0 on my workplace in a windows domain. I download the package (tested 32bit and 64bit), extract them and start the processing.exe . The splash screen shows just in time, but it takes about 10 minutes or more to show the IDE. If I load a sample and press run, the icon looks green but nothing runs. no errors in the log area.

in windows firewall java.exe from processing folder is allowed incoming and outgoing connections.

I tested on my personal computer at home, there is no problem.

(3.0b6 have the same behavior like the 3.0)

Can anyone give me a hint what could be the problem?

many thanks KS

Answers

  • edited October 2015

    Hello there klsc, i cant help im afraid but i am having exactly the same issue.

    Would love to know the solution so i can crack on with my project.

  • I'm just passing to see if I can help in something. Try updating Java. Use 32bit. Maybe you can run it from a USB since processing is on a folder.

  • USB flash drive

  • I think there is a complete java runtime in the processing zip package. I tested 32bit and 64 bit both have the same behavior.

  • first I have not installed oracle java. processing needs over 4 minutes to start the ide. I dare not even to test start a sketch. It wont be successful. then I install oracle java runtime, reboot the windows 7 and test again. -> still 5 minutes to start the IDE.

    hint: If I click the "run" button, it changes the color , but within 5 minutes nothing is starting. no errors in the log area, nothing. console and errors are empty.

    I tested processing 3.0.1 64bit and 32bit, same issue :(

  • should be the domain wide installed kaspersky antivirus? I can't deaktivate it :( I allow if Windows firewall asked.

  • I downloaded Processing 3.0.1-Windows64.zip on my PC (Windows 8.1). When I launch "processing.exe", the "Processing 3 An open project ..." window appears for 1 second then ... disappears. A different window, but the same problem, if I launch "processing-java-exe". This is probably a very trivial question ... any suggestion? (I had no problem with Processing 2.2.1)

  • ok i get the same error on my domain, solution for me is to go in preference file: C:\Users\%username%\AppData\Roaming\Processing\preferences.txt (when app not launched) then change proxy settings... " proxy.http.host=xxx.xxx.xxx.xxx proxy.http.port=xxxxx proxy.https.host=xxx.xxx.xxx.xxx proxy.https.port=xxxxx proxy.socks.host=xxx.xxx.xxx.xxx proxy.socks.port=xxxx " and evrything goes faster. regards.

  • I had exactly the same issue with 3.0 as @klsc in the first post. I've just uninstalled java from my computer and 3.0 is able to start normally :).

    The idea came from the best answer by @didili in this thread: https://forum.processing.org/two/discussion/12578/#Comment_56862

    I didn't have Eclipse, though.

  • as I start with the problem I had not installed any java package and no eclipse too.

    I want to test it next week.

  • For your Information: I deinstall java runtime in windows system settings (like the beginning) but the behavior is the same. IDE start is more than 4 minutes, Sketch running does not work, no error message, no output nothing. I test to configure a proxy in the preferences but no improvement. The condition is the same as a few months ago. I can not use processing on my workplace within the windows domain and installed kaspersky av. :(

  • I have it run! I don't know why, but if I start processing with a local windows user account, it works perfectly. start as domain user -> problems describe above. The local user must not be an admin!

    hint for domain users: you can start the program from your domain login enviroment with the command tool "runas /user:localusername". of course, the local user must be exist before.

  • The same issue as "klsc" posted was seen on my work place but it was solved by setting proxy servers and ports in preferences that "lardonfou" suggested. Thank you.

  • Thanks lardonfou, this worked great for me - P3 wouldn't load or took ab-sol-ute-ly ages to do so. I have yet to solve this for domain users with their roaming profiles, but it's a start!

  • Hi. I'm brand new to Processing and have had this exact problem. I can run Processing at home no problem but not on either of my work computers which are on a domain. We do run a proxy server but it's not enforced so I can by-pass it. In my preferences file I change this line "proxy.system=true" to "proxy.system=false" and now Processing runs normally. Just wanted to share on this old thread in case it helps anyone else.

    Thanks

  • The option "proxy.system=false" works. But in processing 3.0.1 it was not available.

  • Adding the proxy configuration fixed the problem for me. So changing "proxy.http.host=" to "proxy.http.host=myproxyserver" and so on for https and socks. On the way I uninstalled java on the machine, but that didn't fix the problem

Sign In or Register to comment.