android SDK could not be loaded.

edited September 2015 in Android Mode

Getting the first "hello world" app to run is usually very frustrating, and this is no exception. I'm sure many people have had this problem, but i can find a clear explanation of what to do.

I'm trying to follow:

i'm using windows 10, and i just got the newest processing.

I got the "Android SDK Manager" and i checked and installed just about everything on there. When i tried to install android mode in processing I got the message "the android SDK could not be loaded. Use of Android Mode will be all but disabled." I rebooted and open processing again, and the same message pops up while processing is initializing.

maybe it is installing to the wrong folder, or i need to tell processing where to find the SDK.

btw: I got the SDK from here: and went down to "SDK Tools Only" and d/l-ed installer_r24.3.4-windows.exe

i'm totally stuck please help



  • edited September 2015

    There is a target sdk option under android menu, do you have any options in there?

    Edit: Here is a link, where it is explained how to set a path to sdk.

  • @rythmiccycle --- the target option cannot be used as you cannot launch the android mode --- you have to verify where processing is looking for the sdk; as for that you can open (processing closed) the preferences.txt and see what is the android sdk path. this line has to be among the first ones; if there is not any ( guess that it is your case) you can add it manually with the path to your sdk.If this does not work delete processing, delete the preferences folder and try again

  • Thanks for the reply.

    I'm looking for preferences.txt, but i can find it. I have the 64bit processing 3.0. In the folder there are "processing.exe" "processing-java.exe" and "revisions.txt" i did a search in the folder and the closest thing i found was "org.eclipse.equinox.preferences.jar" and I'm pretty sure thats not what you're talking about.

    I'm still stuck! !!

  • @Ater i read that page before i posted here. The problem I'm having doesn't seem to be included on that list.

  • @rhytmmiccycle== open processing go to the left of menu see preferences click there you can see the path to the preferences.txt (probably in the system) note this path close processing (and any instance of it) using the path go to preferences.txt open it (notepad, textEdit..., bbedit...) look at the very beginning: is there a line wich begins with "android_path==" if yes verify that it is good if no you can add it manually then evrything must be ok you can also find && edit your .bashProfile whre you can look at the SDK path

  • I found the preferences, and there was no "android" anything in there. I tried the android path thing like you said but its not working. I'm going to mess with it more later on, if it doesn't work i will then give a more detailed explanation of what u tried.

    @akenaton are you sure there is an underscore and 2 equal signs. Or is a dot with one equal sign? "android_path==" OR "android.path="

  • @rytmccycle ill explain tomorrow (i work...) not to difficult if there is not that line how your sdk can be found???

  • edited September 2015

    @akenaton I really appreciate your help.

    I add the code: "android.path=C:\Users\Michael\AppData\Local\Android\android-sdk" to the top of preferences.txt, saved it, and reopened processing. Sadly, I'm still getting the same error.

    I also did the same thing using: "android_path="
    But its not working.

    I also tried removing android mode from with in processing, and reinstalling the mode; That is not working either.

    I tried googling, "android.path" and "android_path" and i can find anything that seems relevant.

    I don't know what else to do.

    (eagerly awaiting more help)

  • In the link I gave (even if it is not describing your concrete problem) it is said that property is called android.sdk.path, also there are suggestions on verifying System PATH variables, that may be the case.

  • edited September 2015 Answer ✓

    @rythmiccycle in MY preferences.txt here are the first lines WITHOUT Quotes:



    this path is not default one, i have choosen the Developer dir to put my sdk and you can put it where you want --- it s possible that now (having already installed the android mode and so on) you must have to make a completely fresh install for processing.

  • I have made some progress, but it is still not working. I put the following as my first 2 lines in the preferences.

    android.sdk.path=C:\Users\Michael\AppData\Local\Android\android-sdk android.sdk.version=17

    and then I reinstalled "Android mode." The good news is that I didn't get any errors while installing (i was before.) The bad news is that now i'm getting a new error message when i boot up processing

    "Android is not compatible with this version of Processing. Try updating the Mode or contact its author for a new version"

    I think the problem is in the line "android.sdk.version=17," maybe 17 is the wrong number. But i'm not sure what other numbers to try.

    (I almost go it working!!, but not yet)

  • @rhythmiccycle:: ok for the 2 lines, now path is known...(maybe you have to add one when using the emulator (another headache) for setting the port... now for the error::: 17 is the good number for the last version of processing; but (perhaps) you need to update the mode, going to mode menu && selecting android mode installed. I am not sure about it but i see that in my mode folder i have a folder called "old" which means that there was an update that i have made though i cannot remember exactly when and how...

  • @akenaton Thanks, it might take me a couple of days to try everything you said. (i also work & have a family) I'll re post what happens after I do it.

  • @rhyymiccycle=== i work too but as a java/android developer[monney] + artist!!![not so much!!!] if it works don't forget to put answered, for others! --- but after that:: a lot of new problems ----emulator is the first one, it is waiting && laughing...

  • @akenaton OK! more progress!! I found an update button under the "Add mode...." menu.

    And I got something to show up on my phone!!

    thank you!!!

  • @akenaton and @rhythmiccycle == would like to seek your help for my query on this similar forum but with MAC, Anyone one can help me in guiding the right step?

  • @FJP:: i think that everything is explained here, yet

    a) install processing in your Applications dir and give it a workspace (on MAC e.g in your Users Documents folder) b) download SDK, unzip it and put it where you want. But Not in the Library or System or App folders. Note the path to it including the folder name (Android-SDK or something like that c) launch processing in java mode and try to install the android mode. If it asks "where is your SDK..." browse to the folder d) if you get the error "the android SDK could not be loaded. Use of Android Mode will be all but disabled." quit processing, look for your preferences.txt (on osx this file is probably in your users/library/processing, anyway it is possible to find it from the app itself in menu preferences, at the bottom) e) in preferences.txt, if it is not present, add the path for SDK at the first line, the version at the second one, here you must be very precise, see the example in the posts before: no Quotes "" in my case for an example i have:

    android.emulator.port=5554 android.sdk.path=/Developer/android-sdk android.sdk.version=17 --- but of course this My case!!! don't cut & copy!

    f) save your preferences, reopen processing and see g) if it works but claims about incompatibility go to your mode menu and update the SDK.

    Note that as you have already done a lot of things the better could be to begin to delete all you have done, processing.ap, sdk dir, preferences.txt and make a new fresh install

  • @akenaton: Thank you for the reply. I have managed to connect it, however, the next new problem that was raised is that when I run my processing sketch in Android Mode it gave me a message after debug --> "It could not create a virtual device for the emulator", do you have any suggestion for this problem?

  • @FJP: first go to your AVD manager, verify that 1 emulator (or more....) is listed as valid if so try to start it after having selected it) see what happens second go to your sdk manager and see what is installed; install or update what is needed according to your processing version. For 2.X API 10 must be installed (2.3.1); for 3.X API 17 must be installed. third verify that in your prefrences.txt there is (at the third line) a port (usually 5554) assigned to the emulator

  • @akenaton: Thank you so much for your help, will check and see on the steps.

  • @akenaton: where do you get the info that API 17 must be installed, the wiki says it is now 15 (was 10 on 2.x)

  • more adventures ... may be of use ?

    I just installed 3.0 having been on 3.0b6 and the error appeared again ... :(

    A quick look in my modes folder showed me that a new AndroidMode folder had been created and the the previous one (containing the sdk) had been archived into a folder called "old", so I moved my sdk folder into the new AndroidMode folder. I still got the error, but then switching to java mode and back to android mode forced the dialogue that allowed me to select the sdk path and now it all works again:)

Sign In or Register to comment.