Sketches not running

edited January 2016 in Using Processing

Hey guys,

I'm an absolute noob here so please forgive me if I'm asking a stupid question. I just decided to jump into processing and this is really frustrating for me.

I opened the first example of arrays from the library and when I try to hit run I get no result. Earlier I got an error message which said - "Setting 'Run Sketches on Display' preference to display 1" but now I dont even get the error.

Theres just no response.

Any help please??


  • Hi, I'm having the same problem here. I'm trying it with the code size(200,200); and just nothing happens, except for the "Setting 'Run Sketches on Display' preference to display 1" message.

    If I try to use debug, Processing just freezes and I have to kill the java processes. It happens on both XP and W7x64.

    The same code works good on Processing 2, but I've been asked to deploy P3.

    Any help welcome :)

  • the thing to do is to start processing from the command line so you can capture the output and any error messages that appear.

    just don't ask me how to do that with windows. command window, something, something.

    (but part of me thinks it's the jwdp port clash thing i've seen elsewhere)

  • Hi I have experienced the same issue, but even when I run processing via command line (On a Mac OS X 10.11.1), no errors are generated. I am able to run --build, but not --run. I can see a java process gets started, but nothing else really seems to happen. I know it's not a fix, but want to see if I can add more symptoms for triaging.

  • Anyone managed to fix this? Having same issue here.

  • Answer ✓

    Ok, for anyone else having this issue: i solved it by uninstalling Eclipse and the other java environments i had on my computer

  • I'm having the same problem but not sure how to go about uninstalling java environments. Is this the same as removing java completely using the terminal? (mac)

  • Uninstalling all Java Environments will cause more problems, since they use a lot of java-based apps in my school.

  • i think we need a sticky thread about this, it keeps happening more and more.

  • Hi, same problems, and uninstalling all java Environments doesn't fix. But it works on others PC with Java installed. I don't understand !!!

  • Please update ! Thank you !!!

  • Seems that the problem comes from our proxy settings.

    If I set the proxy values in my %appdata%\Processing\preferences.txt<my.proxy.ip>




    it will work for my user.

    Even better if I edit the Processing-3.0.1\java\lib\ file, fulfilling the proxy settings, it will work for all users!

  • interesting. i guess that's processing looking to see if there are any updated versions. isn't that an option?

    and did it work if you disconnected the network?

  • I did not try to disconnect the network, since my processing installation is on a server share, so all the users can have the same version regardless of the computer they will use.

  • I am having same problem now. And ı did not understand how I can change preferences.txt file. Any help??

  • your operating system? processing version? antivirus software?

    (alvira seems to be blocking write access to some locations processing needs when starting up. windows, processing 3, 3d sketches...)

  • avira antivirus can block processing sketches from running (Win 10 e.g.)

  • Hi I am running into the same problem and tried all the proxy settings as mentioned.

    Did anyone resolve this issue ? How ?

  • Yeah.It's truely a proxy problem.I'm running a proxy program on my laptop ,so I met this problem.Thanks PMCurie_IT !

  • I have this problem too, and I edit proxy, the problem is solved!! Thanks for PMCurie_IT

  • edited November 2016


Sign In or Register to comment.