Has anyone successfully exported a Processing app using Simple-OpenNI on Mac OS X?

edited August 2016 in Library Questions

Has anyone been able to successfully export, then run, a Processing app using Simple-OpenNI on Mac OS X? I've tried essentially every trick and suggested fix that my Google search skills could find. I've tried adding Simple-OpenNI through the Processing GUI itself (Import Library) as well as downloading the library straight from the site and dropping it in. So it doesn't seem like the installation is the problem. My sketches all run fine, until I try to export them, then run independently. I get the infamous error:

Can't load SimpleOpenNI library (libSimpleOpenNI.jnilib) : java.lang.UnsatisfiedLinkError: Can't load library: /SimpleOpenNI/library/libSimpleOpenNI.jnilib Verify if you installed SimpleOpenNI correctly. http://code.google.com/p/simple-openni/wiki/Installation Exception in thread "Animation Thread" java.lang.RuntimeException: java.lang.UnsatisfiedLinkError: SimpleOpenNI.SimpleOpenNIJNI.swig_module_init()V [...]

As you can see in the screenshot below, the libSimpleOpenNI.jnilib seems to be present in /Contents/Java but I don't know why the Processing sketch is looking in /SimpleOpenNI/library/libSimpleOpenNI.jnilib instead of looking in its own directory structure (after being exported).

Screen Shot 2013-11-14 at 1.00.23 AM

ie: The exported Processing sketch appears to be looking here (shown below), which is the location of the Simple-OpenNI libraries when they aren't being used in an exported sketch. Even though I have the library installed, it doesn't find it there either.

Screen Shot 2013-11-14 at 1.03.25 AM

My specs/setup: OS X 10.8.5, Processing 2.1 (64-bit), java version "1.6.0_65", Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609), Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

Any help is much appreciated!


  • Oh, friend, so am I!! I have this problem, too. But it say " can't load library(libSimpleOpenNI64.so). My os is Ubuntu13.10. Processing v2.1

  • I can't exported also, is there a fix? I can't find any helpful information.

    I run OSX 10.9, processing 2.0.3, simpleOpenNI 1.96

  • Does anyone have an answer for this question?

  • Not sure if you found a way to do it. The way I managed to do it was by copying the library to the root of the system :) Is not a good way to fix the issue, but it works.

  • edited April 2014

    How did you do this Jonatas? I don't want to install libraries at root of client computers. Has anyone found a fix for this yet?

  • edited April 2015

    Just go into your exported application package: contents/java/, delete the folders "osx" and "NiTE" and copy the whole SimpleOpenNI folder to this directory.


  • So I got some questions about this and to clarify:

    the folder is ...yourapplication/Contents/Java/_simpleOpenNi/

    because the link part in that error /SimpleOpenNI/library/libSimpleOpenNI.jnilib is a relative link and that relation turned out to be to the java folder, like this ...yourapplication/Contents/Java/SimpleOpenNI/library/libSimpleOpenNI.jnilib

    hope it works for you

  • i have the same issue - when I copy the simpleOpenNI folder to the root dir, the application runs (I can tell the processing sketch is running as terminal displays console output) but I can't see anything as the screen is still grey.

    I've tried your suggestion too @fubbi but nothing seemed to work. Did any one end up figuring it out?

  • Are you using Processing 2 or 3? Have you seen https://github.com/wexstorm/simple-openni (untested)

Sign In or Register to comment.