Processing 3: Error occurs during startup

I downloaded the Processing 3 Beta-5 version of processing but I can't get it to run. When I run the "processing" script I see the splash screen and then this error message:

We're off on the wrong foot
An error occurred during startup

Here is information about my machine:

jim@main:~/INSTALL/processing-3.0b5$ java -version
java version "1.7.0_75"
Java(TM) SE Runtime Environment (build 1.7.0_75-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.75-b04, mixed mode)
jim@main:~/INSTALL/processing-3.0b5$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.04
Release:        15.04
Codename:       vivid

What is the problem? Is it reading a processing 2.2.1 configuration file and getting tripped up? (I also have the previous version installed on this machine. it works fine.)

Any help would be appreciated.



  • edited September 2015

    Could you post the whole error message, maybe the Java log?

  • The error message appears in a popup. I can't cut and paste out of it. Does that appear in a log file somewhere?

  • Also note I was just able to get the Processing 3 libraries working through Eclipse. I can make a sketch and view it there.

  • I fixed it! Finally.

    The problem was my Java CLASSPATH. For reasons related to a project I did a few years ago, I had a set of Processing jar files (probably 2.2.1) in a directory that was always in my CLASSPATH. I realize now that this is not a good idea but it made sense at the time.

    When the Processing startup script runs it adds its own files and directories to the end of the CLASSPATH before launching the application. Since my other set of Processing jar files were ahead of the correct jar files, the JRE would load classes from those jars first. Not surprisingly, that is bad for Processing.

    To fix it, I simply had to simply remove my addition to my CLASSPATH. It worked right away after that.

  • edited August 2016

    Weird, I've got my CLASSPATH=E:\Portables\processing-3.1.2\core\library and got no problems whatsoever! @-)

Sign In or Register to comment.