Serial Port Problem "Error opening serial port COM1: Port not found"

edited April 2015 in Arduino

Hello guys, I am a student who is working on my bachelor thesis.

I am dealing with stepper motors and the controller using Arduino, and I am creating a GUI for my stepper motor to control it. I try Processing, and it seems simple and powerful enough.

However, I encountered a problem when I am running Processing program. "Error opening serial port COM1: Port not found"

I use Ubuntu OS 14.04, Processing 2.2.1, and Arduino IDE 1.0.5.

This problem appeared as soon as I run my processing code, right after I uploaded my Arduino code.

Anybody can help to fix this issue?

Thanks very much! :)


  • edited April 2015 Answer ✓

    Are you sure Ubuntu OS represents USB ports using "COM" notation.? I remember using "/dev/ttyS0" ... Anyway, Connect your Arduino and run this code:

    import processing.serial.*;
    Serial myPort;
    void setup(){
    String portName[] = Serial.list();

    In your Processing console you will see the all connected USB ports find the Arduino's and paste it instead of COM1. If there are many ports : check(run) the console when arduino is connected and check(run) it when it is not connected... the missing port should be arduino's.

  • I got it! Solved my problem. The address is /dev/ttyACM0.

    Thank you very much.... :)

  • Not related to Developing Processing (you don't compile it yourself, are you?), so I move the topic.

Sign In or Register to comment.