Is there a bug in the new Python Mode?

edited February 2016 in Python Mode

When I try to do some simple stuff with the updated Python mode I get:

console: Failed to install '': java.nio.charset.UnsupportedCharsetException: cp0.

Is it my fault or is it a bug?


  • I just installed Processing in a new computer and I'm getting this error too when trying to run in Python mode. Java mode works fine.

  • Which version of Processing? How are you installing the Python mode?

  • I have the same problem. On my old computer (Windows 7) no problem, but on my new one (Windows 8) I have the same error message. I have installed processing 2 (I've tried 32 et 64 bits). I've installed python mode by the "Add mode..." menu. Is there an explanation and/or a solution ?? Thanks for any help...

  • I also cant get access to the Python mode. I've downloaded Processing 3.0 for Win 7 x64 & when I try to install the Python mode its greyed out.

    I'm guessing nobody knows why as this question has been unanswered since February!

  • The link you provided doesn't provide a solution. Has anyone found a solution? I have tried re-installing Java to a 64 bit installation, but it didn't help.

Sign In or Register to comment.