Forum is back up after security update

Hey all!

We had to update the forum software due to a critical security update.

The theming is not finished now, but i think we are close enough to open up again ... wouldn't wanna keep you waiting another day. I will finish up later this week, any comments welcome.

Ah, and if you find any quirks or bugs … feel free to ping me.



  • Screen Shot 2015-01-17 at 1.28.03 PM

    ... test image. ;)

  • After 2 years still wating on your promise to include an underline button! :|
    Forum seems neater now anyways! :bz

  • Wow! Nice job!

  • @gotoloop i'll see what i can do about that :\">

  • An underline will get confused with links unless the link formatting can be changed.

  • Looking good, nice to have the forum back - good job! ^.^

  • BTW thanks for getting the forum back online I was starting to get withdrawal symptoms :D

  • Great that it's back :)

    I find a bit overwhelming the amount of information on the front page. I tried some changes using Firebug:

    First I removed the horizontal lines between the topics. Then I went further and removed the details. Added more white space around the topics, around categories and filters. The tag counters have lighter background and bold text.

    I could send the css if it's of any use.

  • Testing HTTP links inside code blocks:

     * ClickLine (v2.0)
     * by GoToLoop (2013/Apr)
    final static color BG = #4080A0, FG = #FFFF00;
    final static short BOLD = 3, FPS = 30;
    void setup() {
      size(600, 400);
    void draw() {
      println(mouseX + "\t" + mouseY);
      if ( (frameCount & 1) == 0 ) {
        point(mouseX, mouseY);
      line(pmouseX, pmouseY, mouseX, mouseY);
    void mouseClicked() {
  • edited January 2015

    Testing @ inside code blocks. And seems like <pre lang="coffeescript"> isn't recognized either!

    Trailing Deque (v3.54)
    by  quarks (2013/Feb)
    for rialobran
    mod GoToLoop
    MAX_TRAIL_POINTS = 5; trails = []
    BG = `0350`; FPS = 30
    GFX = JAVA2D   # use JAVA2D or P2D
    setup: ->
      size 600, 600, GFX; frameRate FPS; smooth 4; do noLoop
      stroke PointXY::FG; strokeWeight PointXY::BOLD
    mousePressed: ->
      trails.push  if trails.length is MAX_TRAIL_POINTS
      then         trails.shift().setXY mouseX, mouseY
      else         new PointXY mouseX, mouseY
      do redraw
    draw: ->
      background BG
      tt = trails[0]
      tt = t.lineXY tt  for t in trails
    class PointXY
      FG: 0xff0000FF; BOLD: 3
      constructor: (@x, @y) ->
      setXY:  (@x, @y) -> @
      lineXY: (other)  -> line other.x, other.y, @x, @y; @
  • edited January 2015


    Was going to complain how words between <> in plain text got removed but that seems logical

  • For <, replace them w/ &lt;. :-B

  • Thanks for your work. I appreciate the new look, quite neat. One bug: the Recent Discussions page no longer have navigation links, to go to the next or nth page. We still can hack by adding /p2 and similar in the URL, but that's annoying.

    Quick test:

    int v = 1;
     * Long standing bug with block comments.
    void setup()
    /* New comment. */
    void draw()

    Ah, and Ctrl+K shortcut for code should be restored, too...

  • edited January 2015

    Ah, and Ctrl+K shortcut for code should be restored, too...

    Appears it's ctrl+o now.

    Another thing I noticed is the new "Best answer" feature. This places the best (first?) answer on top, but also removes it from the discussion below. I don't think that's a good idea as it disrupts the discussion.

  • And, Ctrl+O works, but it is less intuitive than something that formats to Kode... And the change is annoying, as we have the forum full of advices to use Ctrl+K! @-)

  • _vk_vk
    edited January 2015

    This "multiline comment" behaviour is old:

    testing /** :

      int v = 1;
       * Long standing bug with block comments.
      void setup()
      /** New comment. */
      void draw()

    yep this still working

  • Thanks for collecting these, will fix asap (later this week)

  • Side note, for the record (not sure if you can do something; hopefully there are some settings, though): the plugin allowing to elect "Best answers" is nicer in this version, but there are some gotchas: I would make the "Did this answer the question? Yes • No" line less prominent (smaller font, grayer), and it moves answers out of the thread, making the discussion nearly unintelligible! See, for example:

  • I agree with @PhiLho that moving the answers out of chronological order is confusing.

    Unlike other forums the Discussions here are more like conversations because the OPs are asking more open / general questions compared to those you find on StackOverflow for example.

  • Recent Discussions shows the latest 30 or so discussions. How do you view the 30 or so before them? I can't see a way to do this but then I might just need new glasses. :)

  • When I'm notified about some1 accepted my answer or mentioned me, there's no link for it! 8-|

  • @quark: I mentioned the issue (and a solution) there shows the second page, /p3 for the third one, etc. Always worked in the forum, I used it as it is faster than locating the links at the bottom of the page. But of course, it is a hack, and we should have the links back! (I think fjen is working on it.)

  • @PhiLho thanks for the hack missed it first time :)

  • edited August 2017

    I get a notification

    • Kendra accepted Your answer.

    I can click on Kendra and Your (my own profile) but I don't get to the thread?

    This would be useful...

  • @chrisir .. where does it take you? What is the URL?

  • edited August 2017


    url is initially

    there are 2 links in the sentence "Kendra accepted Your answer."

    • One is Kendra -> his profile

    • One is Your -> my own profile

    I miss a link in the word "answer" that leads to the thread where the answer is.

    If it says "X accepted your answer' then you can click on x and your. But there is no way to go to the actual answer.

  • Aha. The Q&A plugin got updated ... seems to have changed. Will see if there are settings for this somewhere.

  • Thank you!

  • In style.css, there is a line with font-size: small;. It makes messages hard to read, IMHO. Why not remain at the default browser size?
    If I deactivate it (with Firebug), comments look good, but the initial message (with a different class) is bigger, for some strange reason. So are the category section, etc., so this would need some adjustments here and there.

  • Is the default mode of messages set to Discussion instead of Question?
    If so, why? Workaround for the problems above?
    Otherwise, it isn't a good idea, as 95 % of threads here are questions...

  • I think it can not be set otherwise. I will double check to see if that can be changed.

    … the new Q&A is very different from the old one (which does not work anymore).

  • Hey, guys seems like not so many people know that the website is back. Could I help in any way? I know that may be a little out of my league, but I would like to help because this website has helped me so much.

  • Hey all … not enough time atm to get this finished. Just to let you know i'm still here and will finish up once i have some air.

  • I know the feeling... Thanks for stopping by to get us updated, anyway.

  • edited February 2015

    Don't forget the option for underline you promised since the beginning. :)
    Very tiresome typing <u> ... </u> all the time for years! #:-S
    At least some CTRL+key combination, please! [-O<

  • Seems like my help is not need then.

  • Hi, I have noticed that there is no "more old post" button in discussion section. Also when I search any keyword, it only shows me the limited number of search results which can fit in one page and there is no button for "see more results".

    Is it a bug?

  • @blyk thanks for reporting … i think i might have accidentally styled them away.

    Still stuck in work … but will get to the forum really soon!

  • blyk, anyway, don't search from the forum itself, search from the main site, it offers a much wider range of results (beyond only this forum).

  • For some reason I don't see the 'new' tags anymore. Also the notifications are horrible.

    If it says "X accepted your answer' then you can click on x and your. But there is no way to go to the actual answer.

  • edited February 2015

    clankill3r, my understanding is that the yellow new tag appears when you opened a topic (or perhaps if you answered to it) and a new message has been posted.
    Other new topics are visible only because they have a clearer background (in the list) than old topics.

  • i can't get to "more posts" within a section. only the default amount (35)

  • The same problem also for me: i can't get to "more posts" within a section. only the default amount (35)

  • edited March 2015

    Append /p2 /p3 and so on to the URL! :ar!

  • cheers GoToLoop ... will work with that for now.... :-)

  • Thank you for the site, thank you for the videos, you are great person!

  • Hello !

    Sorry to ask...

    Even if it's possible to work with "/p2","/p3",... to access to the other pages, could it be possible to correct the bug once for all and get the "next" & "previous" button back ?

    This is not at all the kind of work I use to do but I'm ok to try if you have no time at all to do it (just tell me how I can do my tests, I'm not very familiar with that kind of work)


Sign In or Register to comment.