Cannot install Android mode

edited August 2014 in Android Mode

When I try to install Android Mode from within Processing I get the message "Could not find a mode in the downloaded file" in the Mode Manager window. However, the other modes could be installed without problem.

I've also tried to download the Android Mode manually to the modes folder, but it never gets recognized and included in the mode popup.

Processing 2.2.1, OS X 10.9.4.

Did anyone else have the same problem?





  • edited August 2014

    Hi, here is the workaround i use for osx 10.9 processing 2.2.1. this works for me

    1. get my built-from-source AndroidMode files which uses API level 19 (unzip, folder AndroidMode goes into the modes folder)
    2. add a JDK (I use jdk1.7.0_67.jdk which installs into /Library/Java/JavaVirtualMachines/jdk1.7.0_67.jdk) to the Processing app's Package Contents (control-click onto Processing app icon, select Show Package Contents)
    3. the jdk1.7.0_67.jdk folder goes inside Contents/PlugIns (a folder jdk1.7.0_55.jdk already exists here, but it does not provide the required jdk files to compile to android)
    4. open info.plist inside folder Contents and change jdk1.7.0_55.jdk to jdk1.7.0_67.jdk
    5. now save info.plist
    6. start Processing 2.2.1
    7. switch to Android mode, write some code, upload to phone
  • I am getting the same error when attempting to download to a Windows install. It seems now does a 301 redirect to the wiki. Is this intentional?

  • sojamo: It works great except I'd need it for API level 17 or earlier. But thanks anyway!

    ff8jake: That's the url Mode Manager is using?

    I've reported the issue here.

  • I can confirm this problem exists on Linux as well. Trying to get AndroidMode working (again) with sojamo's AndroidMode files...

  • sojamo: I can't get step 2: (control-click onto Processing app icon, select Show Package Contents) to work. I'm on a Windows System 7 machine. I tried control-click on the icon, examined the Processing files. I see nothing that says Show Package Contents. Am I looking in the wrong place?

  • I got the same error and I solved it. I am a Japanese and windows user, so what I write here may be a little bit different from your circumstances.

    First, there are two "modes" folder in my computer. One is in the same folder that "processing.exe" is in. Another is in "Computer/Document/Processing/modes". "AndroidMode" folder needs to be made in this folder.

    I'm not good at writing English. If you can't understand what I write, ask me.

  • RoramQ: I try to apply your solution, but without success. Could you precise the content of the AndroidMode folder ?

  • modes Is this what you want?

  • yes it seems to be same content as my folder, but it doesn't work. Thank you very much

  • edited September 2014

    I also had an issue with getting the AndroidMode downloaded and installed on my OSX 10.9 machine through the Mode Manager. I tried Sojamo's approach but his didn't work for me, when building an Android app from that build I got fatal errors. So, decided to try my hand at building my own. Here's the steps that got it working for me, hope this helps someone. Mainly using the terminal, I'm assuming you're familiar with that.

    • pull / download the processing git repository
    • pull / download the processing-android git repository
    • you'll need Ant to compile stuff. Ant's not part of Mavericks by default so you mighty need to get it. I did that through Homebrew by typing brew update, followed by brew install ant.
    • now that you're already in a terminal window, you need to set some global variables which Ant needs. You'll need to set export ANDROID_HOME=/Applications/android-sdk-mac_x86 and export ANDROID_SDK=/Applications/android-sdk-mac_x86 where the path is obviously the path to where you have your Android SDK installed. Mine's at /Applications/android-sdk-mac_x86, yours may be elsewhere. I actually added these to my .bash_profile so they'll be available everywhere from now on, but to be honest I'm not sure if the Android Mode in Processing needs those variables to be present always.
    • before starting to compile stuff, let's edit some Ant build-files first. In the processing-android git repo, I needed to edit the build.xml in its root dir and the one in the /core dir. It's one of the first lines, which points Ant to the processing git repo you just downloaded: <property name="processing.dir" value="../../processing" />. I just hard-coded the path to that directory in the value field, but you could enter a relative link if you wish.
    • cd into the processing git repo. You'll need to execute a build command twice, from two different subdirectories, one being /core and the other /app. Just cd into them and type ant build.
    • assuming all went well, now cd into the processing-android directory and execute ant build, followed by ant dist.
    • again, if all went well, there will now be a file in the /release directory in processing-android, which you can unzip into your ~/Documents/Processing/modes directory

    Hope this helps anyone and I hope I didn't gloss over any other dependencies that this walk-through might need.

  • Any windows workarounds?

  • Bernd found out how to make it for Windows on this post:

    Hope I helped who needed :)

  • Worked like magic :)

  • The fix on Windows is to install pre-release 3.0a4.

Sign In or Register to comment.