SimpleOpenNi Library not working with Kinect1414, Processing 2.2.1 & Mavericks 10.9.3

edited June 2014 in Kinect

Hi! So I recently purchased a Kinect 1414 which I was planning to connect to my new Mavericks OSX 10.9.3. I installed Processing 2.2.1 and OpenNi. I know that that the Kinect and the OpenNi are working because I tried them with Synapse and they are also working with the OpenKinect library in Processing. Correct?

BUT when i try to work with the SimpleOpenNi 1.96 library i am having some serious problems.

At first I received an error:

#A fatal error has been detected by the Java Runtime Environment:
#  SIGILL (0x4) at pc=0x000000011982e0b4, pid=570, tid=52247
# JRE version: Java(TM) SE Runtime Environment (7.0_55-b13) (build 1.7.0_55-b13)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (24.55-b03 mixed mode bsd-amd64 compressed oops)
# Problematic frame:
# C  [libfreenect.0.1.2.dylib+0x40b4]  freenect_camera_init+0x178
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again

After initialization:
Could not run the sketch (Target VM failed to initialize).

So I resulted that there must be something wrong with the SimpleOpenNi library. I went through some other discussions where I saw that people would solve this problem simply by replacing the libfreenect.0.1.2.dylib and libusb-1.0.0.dylib files with an older version. When I tried that, I received the following error:

SimpleOpenNI Version 1.96
After initialization:

SimpleOpenNI Error: Can't open device:      
DeviceOpen using default: no devices found

Can't init SimpleOpenNI, maybe the camera is not connected!

I am really lost. How can I make the SimpleOpenNi library work? Can anybody help me?


  • Hi cuckoo_clock

    Did you config the systems to kinect works? I have the same problem with the same configuration:

    Processing 2.2.1 - Mavericks - simpleOpenni 1.96 - Kinect 1414

    Please any help, thank you.

  • psapsa
    edited November 2014 Answer ✓


    (have not been following the forum, just noticed today)

    I had this problem. With more recent processing (> 2.1 ?) the dynamic libs that come with simpleopenni do not seem to work.

    I solved it by first installing libusb and libfreenect, e.g., if you use homebrew:

    brew install libusb

    brew install libfreenect

    and then making a symbolic link, to replace libfreenect.0.1.2.dylib in the simpleopenni distribution, and also remove the libusb file that comes with it. E.g., in my case I have libfreenect.0.2.0:

    cd processing_sketch_dir/libraries/SimpleOpenNI/library/osx/OpenNI2/Drivers

    rm libfreenect.0.1.2.dylib

    ln -s /usr/local/lib/libfreenect.0.2.0.dylib libfreenect.0.1.2.dylib

    rm libusb*

    (simply replacing libfreenect.0.1.2.dylib by the more recent libfreenect does not work)

    Now there is a more recent libfreenect, 0.5 I think. I have not tested it but in principle it should work.

    Hope this helps.

    Regards, Paulo

  • Hi,

    Thanks a lot for your help. This is the right way to solve the problem. Just one thing, libfreenect.0.5.0.dylib is in a different folder:

    cd "processing_sketch_dir"/libraries/SimpleOpenNI/library/osx/OpenNI2/Drivers

    rm libfreenect.0.1.2.dylib

    ln -s /usr/local/Cellar/libfreenect/0.5.0/lib/libfreenect.0.5.0.dylib libfreenect.0.1.2.dylib

    rm libusb*


  • edited December 2014

    Just an update for whoever tries that. If you use homebrew to download libfreenect and libusb, for libfreenect it says that it is downloading version 0.5.1 and that would be the name of the folder, but the actual dylib file is (for some reason...) 0.5.0! so the command would be

    ln -s /usr/local/Cellar/libfreenect/0.5.1/lib/libfreenect.0.5.0.dylib libfreenect.0.1.2.dylib

  • Hi,

    Yes I used homebrew to download libfreenect and libusb. Yes would be that url.

    I tell you my adventure with simpleopenni and the final I leave this library. Apple bought the company who develop simpleopenni and forgot us. Apple is changed... :(

    When I update to Mavericks this solution was fine to me but later I have many problems with SimpleOpenNI. Two weeks later I bought a SSD and when installing with timemachine backup again was broken. And then make this:

    And works but many functions of library are changed or removed and it's very difficult to works with.

    Try with this:

Sign In or Register to comment.