Movie Maker tool and image format

Hi everyone, I'm using saveFrame() to save images of my Processing display window, and the Movie Maker tool to stitch them into a Quicktime movie.

I'm able to do this correctly with .png images. But when I try .tga or .tif files (as suggested in the Movie Maker tool window), the resulting movie is just black. I see this related discussion:

Obviously I can just work from .png files, but that slows down my sketch much more than .tif or .tga files. Just wondering if anyone else has had the same issue? I'm running Processing 2.1.1 on a Mid 2012 MacBook Pro, Mountain Lion. I'm using the default renderer. Thanks.



  • I never used the tool, so I cannot give a good solution, but I can propose a workaround: create your TGA files, then use some batch tool (eg. ImageMagick) to convert them all to PNG.

  • same problem here. but for me it's irrelevant. i just use png and export with an fps of 1. in the maker tool i set fps to 30.

  • I am actually having the same problem. I saved all my images as tif files and when I tried to create a movie using the built-in movie maker program, it created a video that is all black. The first time I run the video in Quicktime, a window pops up stating that Quicktime is converting the file in order to play it.

    I changed the compression from animation to jpeg with the similar results. At least with using jpeg compression the icon for the movie shows up as a preview of a frame in the OSX preview bar in finder. Switching to png compression has the same results as animation compression. None of the videos play in VLC player.

    I'm on OS 10.9 on a late 2011 Macbook pro using Processing 2.2.1

  • edited July 2014

    Well, you found out this thread, digitalladybug. Have you tried the "solution" (untested!) given here? It is unclear from your message.

  • edited December 2015

    I had the same problem, using 2.2.1. Although, just 2 days ago I was able to use movie maker to export .tiff files to QT and QT was able to convert into a movie. When I tried the same thing today with diff sketches, I got a 72KB file (regardless of number of tiff files 200 or 3000) that showed only a black screen on playback in QT. After trying different combinations of settings in movie maker, the only solution that worked was inside the processing sketch, using: saveFrame("filename-####.png"), instead of saveFrame("filename-####.tif"). I'm not sure why .tif stopped working, but I could not find another solution.

  • Use a separate processing sketch to later convert your .tif/.tga images to .png. Then use movie maker on the new images. If u need help with it comment below.

Sign In or Register to comment.