Has anyone every integrated the twiddler2 and processing? I can type into the development window (i.e. type "void setup" for example), but I can't type into a sketch. When I say "key pressed()" it doesn't register the twiddler in the sketch. Please help!


  • I have no idea of what is a twiddler or a twiddler2. If that's hardware, it should be in the appropriate section. Idem if that's a library... I can move this topic if you indicate what is this stuff...

    BTW, that's keyPressed(), not "key pressed()"...

  • - hardware, but processing compatibility problems... If you could move it to hardware that would be awesome.

  • Done.

    What do you mean by "t doesn't register the twiddler in the sketch."?

    (Perhaps that's obvious for somebody familiar with the stuff.)

  • Awesome. Thank you so much.

    What I mean is that if I write into the development environment with the twiddler it's good.

    So, if I've got a sketch that's like:

    void setup(){ }

    I can write in size(200,200); with the twiddler no problem

    However, once I run a sketch with something like

    void keyPressed(){ println(key); }

    all I get is an ?

    If it would be helpful, I can put in the sketch that I was using, and tell you the detailed output?

  • Answer ✓

    Since twiddler uses multiple keys to represent a character it maybe that Processing sketches only recognises the first key rather than the combination.

    I suggest that you try the keyTyped instead of the keyPressed method - it might work [-O<

  • quark... that worked. Thank you so much!!!

Sign In or Register to comment.