Apde + ketai

Hello everyone, I was trying to use APDE plus the ketai library, just any example in the library I'm throwing an error. the error changes based on the path of the library you are looking for, in this example:

Initializing build sequence... Deleted old build folder Injected log broadcaster No library found for ketai.cv.facedetector Detected architecture arm64-v8a

Packaging resources with AAPT... [/data/user/0/com.calsignlabs.apde/files/tmp/aapt, package, -v, -f, -m, -S, /data/user/0/com.calsignlabs.apde/app_build/res/, -J, /data/user/0/com.calsignlabs.apde/app_build/gen, -A, /data/user/0/com.calsignlabs.apde/app_build/assets, -M, /data/user/0/com.calsignlabs.apde/app_build/AndroidManifest.xml, -I, /data/user/0/com.calsignlabs.apde/files/tmp/android.jar, -F, /data/user/0/com.calsignlabs.apde/app_build/bin/FaceDetector.apk.res] null null Calling by::className:com.calsignlabs.apde.build.Build MethodName:build AAPT exited with error code 1

I do not understand how it is possible, yet the library seems to be installed correctly. Thank you to all.

Answers

  • I recently did the same thing and had the same error.

    What I did to fix it:

    1. Copy all the code from the example (I only tried the Accelerometer and Gesture examples).

    2. Create a new sketch in your sketchbook.

    3. Paste the copied code.

    4. In the setup() function, remove the undeclared variable displayDensity.

    5. Run the new sketch.

    After doing that, I got the Accelerometer and Gesture examples working fine using ADPE v0.4.0 on my Android 6.0.1 device.

Sign In or Register to comment.