Osc5 getting blocked by firewall

edited October 2017 in Android Mode

My android app connects to my server through my domain. Most of the time my apps connect to the server without problems but when I use my school's network I cant connect (I assume the firewall blocked it since the firewall is quite 'sensitive' and blocks a lot of data), I'm using osc5 on port 5204, is there anyway to get trough the fire wall?



  • edited October 2017 Answer ✓

    If your school network firewall blocks port 5204 then the only way is to send traffic on a port that your school allows. This isn't specific to Processing, osc5, or osc -- it is true of any port used for any purpose.

    Two options:

    1. use an allowed port instead, or
    2. if you school allows VPN, you could VPN in to your server and then all ports would be local and thus open.
  • @jeremydouglass Thank you! is there any port that most mobile app use? Most sources say I should use port 80 although that would stop me from hosting a website on the server since its the same port.

    So does this mean I would need 2 public domains? Or is there any other way of doing this, also using a VPN isn't really a option since I want anyone who downloads the app to be able to connect on most networks and asking them to install a VPN is a bit much.

  • If you want anyone to be able to connect on almost any network, that sounds like port 80 -- yes, that would stop you from hosting a website on that server, although you could host https websites at port 443

    I'm honestly not sure if sending OSC data (which I believe is UDP) on port 80 (http is TCP-IP) could cause server or firewall problems. Perhaps someone with more experience can chime in.

  • @jeremydouglass Thank you very much! I ended up hosting the server on de default port 80 since its really inconvenient for user of a website to type www.example.com:443, and I my processing sketch runs on port 443 which seems to work fine and not get blocked.

  • Great! Glad that OSC worked on 443, and that 443 worked for your school firewall. Thanks for sharing your solution.

Sign In or Register to comment.