App created with Processing.JS stopped working on any computer browser but works on a smartphone

Hi there,

I created an app using HTML5 Canvas with the Processing.JS library and it has always worked perfectly until today. Without having modified anything, I’ve noticed that when clicking at a certain point (which is needed to use the app) the whole thing gets stuck and collapses.

This keeps happening using all sorts of browsers on my PC (Chrome, Firefox, Opera…). I’ve tried all the early versions of Processing, as well as the newest.

Apart from this, I’ve tried the app both uploaded on a website as well as in a local host, but the error remains.

However, the apps surprisingly still works fine when it’s opened with a smartphone browser (Chrome, in this case).

Which could be the cause of this problem? And how could I fix it?

*[I’ve uploaded the app here http://probandoapp.000webhostapp.com/6-app.php so that you can see better what the problem is.

In order to use the app (it’s made to draw rooms), you need to click first on the button at the top on the left side (Nueva Sala), then add random small numeric values in the four fields that appear at the top (Posición X, Posición Y, Dimensión X, Dimensión Y) and a room will be created. When you click on it to edit it,it collapses].*

Thanks a lot in advance.

Tagged:

Answers

Sign In or Register to comment.