Canvas size does not fill Android Emulator screen

edited June 7 in Android Mode

I'm using Android Studio and am aware that the size() method doesn't work, so I tried removing it altogether, but my canvas is super small within the emulator. Anyone know how to force it to be fullscreen?

public class Sketch extends PApplet {

    public void setup() {
        background(52,74,85);
        noLoop();
    }

    public void draw() {
        ellipse(width/2, height/2, 100, 100);
    }
}

IMAGE:

Answers

  • Try adding

    void settings(){
       fullScreen();
    }
    

    and see if it works. Also, what Processing version and Android mode are you using? For the AM version, open the Processing IDE, go to Modes and select Android Mode and it will show at the bottom its version.

    Kf

  • When I try the fullscreen() method, it's not recognized. Any idea why? Keep in mind I'm working within Android Studio (latest version)... not within the Processing interface.

    I'm not sure which versions you need to see, so here's my build.gradle file.

  • I can't help atm but in few hours...

    I will tag @akenaton and @codeanticode in case they can assist...

    Kf

  • Found that if I added this code, it works.

    public void settings() {
        size(1080, 1590);
    }
    

    But I'd love it to be flexible so that it can change on device rotation, etc.

  • Answer ✓

    Did you mean "fullScreen()"?

    fullscreen() != fullScreen()

  • Hot diggity, that was it.

  • I tested on a device and on an emulator and I cannot get the 100x100 sketch. If you don't define the size, then it takes fullScreen() (BTW thxs @jeremydouglass for your last comment)

    For the virtual device I was using a nexus_5x API25.

    Even when using noLoop(), the device still response when changing orientation.

    So, try first by fixing the upper case above. Also try by don't calling size or fullScreen in setup/settings.

    Kf

Sign In or Register to comment.