Android Dev. Problems.

edited March 28 in Android Mode

When ever I try to make anything in Android mode it gives me errors for instance: I copied and pasted the demo Android project from the tutorial and it says "the [xyz] does not exist". Also Processing can't find my tablet. But one problem at a time I guess. Any ideas?

Answers

  • Please join the following post: https://forum.processing.org/two/discussion/21588/running-sketches-on-my-smartphone-does-not-work-anymore#latest

    Can you add what have you tried so far? Have you run any application on your device before, for example using Eclipse or AS? What code have you tried? What link resources are you using to get you started...

    Kf

  • http://android.processing.org and random people on youtube. Everything doesn't work. Unless i'm in Java mode.

  • Answer ✓

    Please ignored those commands being highlighted in the Processing IDE. What is important is for you to hit the run button and wait for one full minute or so unless you get any errors. Please note the errors will show in the console as you are aware in red. Notice you need to differentiate between errors and warnings. Warnings are just messages but they will not stop running your program. Errors on the other hand need to be fixed.

    During the compilation process, which takes longer than the java counterpart, if it is successful, you will have the app running on your device. If you get any errors, please post them here. For errors, please copy and paste what you get in the console instead of screenshots.

    Did you enabled the developer mode on your phone? Can you add to this post what device are you using, OS, Android mode version, Processing version, API target.

    Kf

  • Yes I have Dev mode. And USB debugging enabled. I have the SDK and drivers downloaded. But when I click run it does all the build stuff, then it goes to "Running sketch on device" but it's not? Also it doesn't show up in the connected devices? (And I have the correct version for the API)

  • I downloaded the SDK through Processing 3. @kfrajer

  • I downloaded the SDK through Processing 3

    I have seen people having issues when doing this via Processing 3 library (Android mode) manager in previous posts. I suggest you undo it and install it manually. I installed the SDK tools when I installed Android Studio. I think you can just install the Android SDK. Then when you start processing and you switch to Android mode, it will prompt you for the path to your sdk folder.

    However keep in mind the latest version of the SDK tools is not working for processing. It was reported that ant scripts were removed and everything is done via grudle and I believe the Processing community (and many other communities) have been affected by this change. The temporal solution is to use an older version of sdk tools. I am just experiencing this myself so I am also working in setting up proper environment on my side (I upgraded AS last night and now I have to undo few things...)

    Check this: https://forum.processing.org/two/discussion/comment/91836/#Comment_91836

    Kf

  • Wait! I got my device to come up @kfrajer ! But now i'm getting: _Exception in thread "AndroidDevice: logcat process monitor" java.lang.IllegalStateException: I didn't know about device d20ad228! at processing.mode.android.Devices.deviceRemoved(Devices.java:266) at processing.mode.android.Device.shutdown(Device.java:295) at processing.mode.android.Device$1.run(Device.java:278) at java.lang.Thread.run(Thread.java:745) _

  • I feel like we're making progress. Thank you for your time @kfrajer

  • And I was going to just install the SDK before, But I can't find the download for just SDK. Android studio takes to long to download.

  • It does take long time... I think it was like an hour or two after I got everything set and configure... never mind it was eating my HD space so I ran into trouble last night. Just make sure you install an older version of the SDK. I have always installed AS. You should google it and see if there is a way to do it by itself.

    Kf

  • @kfragjer I've tried all i've come across are broken links, and link to AS. Why everytime I run the sketch it tells me it "lost connection while installing"?

  • The first park is to create the apk file. The second part is to transfer it to the device. The third part is to run it from your device. The first part is slow (when comparing it to Java so I understand). It fails in the transfer after the first part so it won't fail immediately.

    However, this is just my thought. Could something else be happening under the hood? Try googling it as this could be observed in other IDEs and their suggestions could be helpful in your case.

    Kf

  • I've been googling this whole time

Sign In or Register to comment.