Video library does NOT work on a fresh installation of ArchLinux - 0.0 movie duration

Hi, I have recently bought an ssd drive and deployed fresh ArchLinux installation. And I have a problem with using Video lib in processing. It simply does not play any video. It shows 0.0 duration and blank screen.

I have: * checked the libraries, firstly installed from repo then also copied my older libraries from sketchbook * installed gstreamer and gstreamer-good-plugins packages and so on. * tried gstreamer-git from AUR * tried chrooting into old system withouth any effect * tried to encode the file with mpeg4, h264, h263 etc. * tried the simpliest video example * chmod'ded 777 the opened file * running processing as root * downgrading to processing2

Nothing does any change. That's not a problem in my sketch, as I have tried the simpliest examples. I am sure also that the file name is correct.

Could you please share with me some ideas where do I look? Thanks in advance!

Answers

  • edited April 18

    I have just created a fork of processing-glvideo, that will allow you to use GLStreamer-1.0 with archlinux, currently experimental but this will likely be future for processing video. I found similar to you with regular video library, I don't think there is a simple fix (apart for using a different distro works fine on Mint), anyway glvideo looks interesting.

Sign In or Register to comment.