Error relating to NEWT Display Class

edited September 2015 in Using Processing

I'm brand new to Processing, (V3, under Windows XP), and have been running the examples in the >File >Examples menu, to get a feel for how 'Processing' works, but for many I get this error:- java.lang.ClassnotFoundException: Failed to find NEWT Display Class<.windows.DisplayDriver>

and in the bottom pane it says: at jogamp.newt.DisplayImpl.getDisplayClass( and at jogamp.newt.DisplayImpl.create(

One example this happens with is "MoveEye"

Can anyone help me to work out what is going on? Any help will be much appreciated. ... Steve

Edit: There are a bunch of other related errors too, that I missed, all starting the same, with "at jogamp.newt......."



  • Make sure you have updated your graphics card drivers. All these errors are related to OpenGL

  • edited September 2015

    I just checked on the Intel website, and I already have the latest available graphics drivers installed. I re-installed, just in case, but no difference. These drivers were written in 2008. Is that likely to be the problem?

  • Possibly but its not my area of expertise.

    Try this in PS3

    void settings(){
      size(400, 300, P3D); // Use OpenGL renderer
    void setup(){
    void draw(){
      background(255); // white background

    This is the most basic sketch. If it doesn't work then try changing line 2 to

    size(400, 300); // Use default Java2D renderer

    If this second attempt works then it is an OpenGL problem, probably related to your computer setup rather than Processing.

    If neither work then I suggest that you try re-installing Processing again.

    If that doesn't work I have no more ideas perhaps someone else will.

  • edited September 2015

    First up, thank you very much for your help, quark. I'll leave this problem open, in case someone comes up with a potential solution. Not looking good, though.

    So it appears to be an OpenGL problem. The first example worked but the second didn't. You're on the right track.

    So I wonder if it is the drivers themselves, or related to my graphics card settings?

    I currently have the resolution at 1280 x 720, needed so that I can also view the PC output on my larger TV screen for videos, but I tried 1920 x 1080 and the problem persisted, so it's not the resolution.

    I installed Processing to accompany an Arduino-related project, which will need Processing when I advance further into it. The library it will use is ControlP5, which I installed earlier. I haven't written a single sketch yet, having only just installed Processing earlier today. I'll be using someone else's sketch(es) to access the ControlP5 library. Is it likely that this problem will affect ControlP5 sketches? (Many of the examples work just fine, it seems that only those that use OpenGL are a problem.)

    Edit: I just tried one example from the ControlP5 Examples folder, "Color Picker", and it worked fine. Things might not be as bad as I thought. I'll try a few more and see what happens. (I'd overlooked the fact that ControlP5 might have included examples. A bit slow sometimes... )

  • edited September 2015

    Almost all ControlP5 examples work fine. I tried about 20. A couple don't, but different errors than earlier, relating to the sketch coding itself, I think. I might be in luck with this project after all. Fingers crossed.

    I'd still like to solve the original problem, though, if anyone has any suggestions.

    So, on the premise that maybe OpenGL was somewhere in the Processing folders and simply not being found, I did an extensive search and found 'OpenGL' in a zipped folder named "", located in "processing-3.0b5-windows32\processing-3.0b5\core\library" Inside the zipped archive is a "jogamp" folder, (jogamp was a key word in my error messages), and inside that is "OpenGL" Insidethe OpenGL folder are numerous folders and files, including many files with the .java filename extension.

    So more questions:- 1. Is the fact that this "" folder is still zipped up likely to be the problem? 2. Should I unzip it? 3. If I do unzip it, should I do so where it is, or is there a specific place that I should place it?

    Once again, any help would be gratefully received. I'm floundering here, and really feeling out of my depth in sorting this out.

  • Further to the edits to the above post, there's also a com\jogamp\newt folder inside the zipped "" folder. "NEWT" was another of the keywords in my original error.

  • Don't unzip the files they are just the source (.java) files. The files of interest are the .jar files and there should be several.

    I am on OSX and this is a view of the files on my computer showing the jar files associated with OpenGL.
    Screen Shot 2015-09-07 at 18.40.05

    I assume that the example using

    size(400, 300, P3D); failed
    size(400, 300); worked

    which means you have an OpenGL problem. Your answer above was a little ambiguous. ;)

    Since you are brand new to Processing you may not realise PS3.0b5 is a very recent release and a MAJOR upgrade over 2.2.1 it means that some (not all) contributed libraries will not work with PS3 until they have been upgraded by the libraries author.

    ControlP5 is a contributed library which seems to work with PS3, just be aware that some won't and the error messages might be confusing.

  • You are correct, the line using OpenGL, with P3D as the 3rd parameter, failed. The other line worked fine, so it IS an OpenGL problem. And all of the files I see in your directory are present in mine, already unzipped.

    JOGL jar files

    So it appears that my problem must run deeper and be associated with my system. I'll just have to learn to live with it, I guess, and hope that no libraries that I use need OpenGL. Such is life. Once again, thank you very much for your help, quark. Much appreciated, even if we didn't manage to sort out the problem. ... Steve

  • Have a look for OpenGL drivers for your graphics card. If possible try PS on another machine.

    I also suggest that you download 2.2.1 and try that version. At the beginners level there is very little difference between them. The example code I posted above is for PS3 the equivalent 2.2.1 code is

    void setup(){
      size(400, 300, P3D); // Use OpenGL renderer
    void draw(){
      background(255); // white background

    Many people are still using 2.2.1 until more contributed libraries and tools have been upgraded.

  • I will download 2.2.1 and try it when I get a chance. I mainly installed Processing for my current project, to use others' sketches as mentioned, but it's piqued my interest now and I'd like to get into it more deeply. Your suggestion of looking for OpenGL drivers for my graphics card is a good idea too. I'll see what I can find. There's a good chance that there will be OpenGL drivers. It's a fairly common Intel 82945G Express chipset.

    It's been a long day with a sharp learning curve. I installed the Arduino software, Processing software and Virtronics simulator software for the Arduino, along with the Arduino Brain Library and the ControlP5 library for Processing. Aside from this one issue, I have everything working well. Time for some sleep now - it's 4.30am here. Yawn. :) Thanks for your help and suggestions.

  • I did some searching/reading today, and it seems that I'm out of luck. My hardware isn't up to the task, will only work with versions of OpenGL earlier than V2.0! A new graphics card is called for, (or maybe a newer PC). I found this:-

  • Thank you for the link, GoToLoop. I'm downloading a copy of V1.5.1 now to check out. A question, if you don't mind - is it likely to work with the examples that are included with version 3? ie If I need to use someone else's sketches that are similar to those in the V3 example folder, will they run or fail? ("MoveEye" for example.)

  • Version 3 made some "drastic" changes at some points.
    Therefore, you're gonna need to convert some details back to Processing 1 & 2.
    With time, you're gonna learn how to do it or know whether it's even possible to convert.

  • Thanks for the extra info.

    Meantime, I can't get v1.5.1 to run. It says it needs at least Java Development Kit (not JRE) v1.5.0, then takes me to the Oracle/Java/ main index page:-

    From there, I'm lost. No mention of a Java Development Kit, v1.5.0 or otherwise.

    I think that for now I'll stick to version 3 and learn to live with it's limitations. I'll revisit the subject when I'm a little less overloaded with new stuff to learn, after I've familiarised myself with the Arduino and it's langage. Most of the ControlP5 examples work in V3, so hopefully when I get to that stage of my project the sketches that I need, (I haven't downloaded them yet), will work. (They relate to brain-wave graphing from an EEG input.) If they don't work, I'll have to do whatever's necessary to make them work. :) Thanks for taking the time to help out though. I do appreciate it.


    Since you're in WinXP, pick "Windows x86" download after accepting the "License Agreement".

  • edited September 2015

    I really appreciate you pointing me in the right direction, GoToLoop. I'm very familiar with C++, but completely lost with the Java environment. I'd never even heard of 'Processing' until 2 days ago.

    When the download completes, (another 12min), I'll see if I can get things up and running. I'll post on how I went later on.

    Meantime, I have a Java 8 update, (Java 8 Update 60), to do that's been sitting on my desktop for a few days. I'll do that first.

    Thank you once again. Without your help and that of quark, I'd still be sitting here scratching my head. :)

  • Gotta be JDK (Java SE). JRE won't cut it! L-)

  • edited September 2015

    I finally got through the process, and now Processing 1.5.1works fine. :) It has the same example, "MoveEye", which failed to run in Processing 3, and it now works.

    I created a new Sketchbook especially for Processing 3, so I can also run it when needed without confusion/conflicts. I couldn't have possibly done this without your help GoToLoop, and also quark's help, so I'm eternally grateful. I owe you (both) one. (I didn't think I was ever going to get it working properly.)

    I'll set both up in clearly labelled locations on my hard drive, and I'm finally good-to-go.

    I now have a double chance of getting the 3rd-party sketches in my project to run, when I get to that point.

    Now for the fun - learning how to write useful sketches. :)

    N.B. I haven't yet tested the ControlP5 library in Processing 1.5.1, but that's next.

Sign In or Register to comment.