Using video library with new Processing 3.0a10 with Java Jdk8 on Raspberry

Dear Friends, I have been trying to use the video library of Processing with raspbian on my raspberry Pi with 2015-05-05-raspbian-wheezy

After I tested the processing-2.2.1-linux32 with jdk7 as specified by http://scruss.com/blog/2014/01/07/processing-2-1-oracle-java-raspberry-pi-serial-arduino-☺/ I realised that video library is not supported

So I tried the new processing-3.0a10-linux32 I did the following $ sudo apt-get update $ sudo apt-get dist-upgradeapt $ tar xvzf processing-3.0a10-linux32.tgz

Then I saw Jdk8 is supported with Processing3.0 \\\\ JAVA VERSION Jdk8 \\\\\ \ https://github.com/processing/processing/wiki/Supported-Platforms \ Processing 3 uses Java 8. Starting in April 2015, Oracle is no longer be fixing bugs in Java 7, so we had to make the switch.

But when starting Processing I got some Java incompatibility errors $ /home/pi/processing-3.0a10/java/bin/java: 1: /home/pi/processing-3.0a10/java/bin/java:ELF: not found /home/pi/processing-3.0a10/java/bin/java: 2: /home/pi/processing-3.0a10/java/bin/java: Syntax error: "(" unexpected

so I followed instructions from http://www.webupd8.org/2014/03/how-to-install-oracle-java-8-in-debian.html to reinstall Java8

$ sudo bash $ echo "deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main" | tee /etc/apt/sources.list.d/webupd8team-java.list $ echo "deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main" | tee -a /etc/apt/sources.list.d/webupd8team-java.list $ apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys EEA14886 $ apt-get update $ apt-get install oracle-java8-installer $ exit

but got same error! $ /home/pi/processing-3.0a10/java/bin/java: 1: /home/pi/processing-3.0a10/java/bin/java:ELF: not found /home/pi/processing-3.0a10/java/bin/java: 2: /home/pi/processing-3.0a10/java/bin/java: Syntax error: "(" unexpected

So I switched back to jdk7

\ JAVA VERSION Jdk7 \\\\\ $ sudo apt-get install oracle-java7-jdk $ sudo update-alternatives --config java $ rm -rf ~/processing-3.0a10/java $ ln -s /usr/lib/jvm/jdk-7-oracle-armhf ~/processing-3.0a10/java

But then I got some font issues when starting processing, and instead of my beloved Processing window, i got a ''font not recognized'' and then.. nothing

Then I found the following: \\\\FONT for JAVA\\\\ \https://github.com/processing/processing/wiki/Supported-Platforms \ If you replace the 'java' folder, you'll lose the default fonts used for the PDE. \ You can get them back by copying the “SourceCode” items from the included java/lib/fonts \ folder to your new java/lib/fonts. so I copied the files of the jdk8 that come with Processing-3.0a10 to ~/video

pi@raspberrypi ~ $ sudo cp video/fonts/SourceCodePro-Bold.ttf processing-3.0a10/java/lib/fonts
pi@raspberrypi ~ $ sudo cp video/fonts/SourceCodePro-Regular.ttf processing-3.0a10/java/lib/fonts pi@raspberrypi ~ $ sudo cp video/fonts/SourceCodePro-LICENSE.txt processing-3.0a10/java/lib/fonts

it still did not work, so I copied all files from font pi@raspberrypi ~ $ sudo cp video/fonts/* processing-3.0a10/java/lib/fonts pi@raspberrypi ~ $ processing-3.0a10/processing

Still got the same: Missing font issue, and Processing would not start

Any Idea?? How to get the Processing video library working on Raspberry??

Answers

  • edited July 2015

    I don't have that hardware, so I dunno!
    But my advice is to stay away from anything past P3.05a until they got a stable release!

  • OK thanks I'll try that. Hoping that it supports Processing video library with Jdk8.. or jdk7..

  • OK so I installed Processing 3.0.a5 with VNC remote viewer and Jdk8, Linux32 (Raspberry Raspbian Wheezy 2015-05-05) I installed the last processing.video library

    When I start processing on my remote terminal, I get: Xlib: extension "RANDR" missing on display ":1". But Processing starts and It starts compiling and then I get:

    Cannot Parse error text: Annotation processing got disabled, since it requires a 1.6 compliant JVM

    Any idea?

  • Hi michel, did you got it working eventually? I'm trying to do the same.

Sign In or Register to comment.